查询显卡型号:

 lspci -nn | egrep -i "3d|display|vga"
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208 [GeForce GT 710B] [10de:128b] (rev a1)

记下Nvidia显卡最前边的编号:01:00.0
安装nvidia-detect

apt-get install nvidia-detect

报错:

E: 无法定位软件包 nvidia-detect

换源:

vi /etc/apt/sources.list

Debian 10 Buster 国内常用镜像源
这里采用中科大源

deb https://mirrors.ustc.edu.cn/debian/ buster main contrib non-free
deb https://mirrors.ustc.edu.cn/debian/ buster-updates main contrib non-free
deb https://mirrors.ustc.edu.cn/debian/ buster-backports main contrib non-free
deb https://mirrors.ustc.edu.cn/debian-security/ buster/updates main contrib non-free

deb-src https://mirrors.ustc.edu.cn/debian/ buster main contrib non-free
deb-src https://mirrors.ustc.edu.cn/debian/ buster-updates main contrib non-free
deb-src https://mirrors.ustc.edu.cn/debian/ buster-backports main contrib non-free
deb-src https://mirrors.ustc.edu.cn/debian-security/ buster/updates main contrib non-free

更新:

apt-get update
apt-get upgrade

再次安装

apt-get install nvidia-detect

输入命令,查看:

nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208 [GeForce GT 710B] [10de:128b] (rev a1)

Checking card:  NVIDIA Corporation GK208 [GeForce GT 710B] (rev a1)
Your card is supported by the default drivers and legacy driver series 390.
It is recommended to install the
    nvidia-driver
package.

显示了需要驱动包:nvidia-driver
安装驱动包:

apt-get install nvidia-driver

中途会有提示nouveau冲突,回车确定。
详细

debian系linux更新时,提示“由于没有公钥,无法验证下列签名”
解决方法
下载导入公钥

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys  8B48AD6246925553

# 此处的8B48AD6246925553、7638D0442B90D010是错误提示中的:NO_PUBKEY 8B48AD6246925553  NO_PUBKEY

Last modification:April 21st, 2021 at 09:43 pm
如果觉得我的文章对你有用,请随意赞赏